We are investigating an error while sending e-mails from Bookingplanner
Incident Report for Stardekk statuspage
Resolved
This incident has been resolved.
Posted Jul 09, 2022 - 10:18 CEST
Investigating
We are currently investigating this issue.
Posted Jul 09, 2022 - 10:02 CEST
This incident affected: Bookingplanner.